Der Scanner will noch nicht …

manjaro-logo-greenEs ist ein ganz seltsames Problem, das ich im Moment noch nicht lösen kann. Mein Flachbettscanner leistet seit Jahren seinen treuen Dienst. Das Modell funktioniert bei jeder Distribution, die ich bisher auf der Platte hatte, ohne irgend eine zusätzliche Aktion wie Treibersuche und -installation. Der geht einfach so.

Kürzlich hatte ich mir Manjaro LXQt im Dualboot zur XFCE-Variante installiert. Soweit, so gut. Abgesehen davon, dass kein Drucksystem vorinstalliert ist, macht diese Distribution einen guten Eindruck. Bis ich auf die Idee kam, meinen Scanner auszuprobieren.

$ lsusb
Bus 001 Device 002: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
$ _

Das sieht gut aus, kommt aber nicht unerwartet.

$ sane-find-scanner
...
found USB scanner (vendor=0x04a9 [Canon], product=0x2220 [CanoScan], chip=LM9832/3) at libusb:001:002

Your USB scanner was (probably) detected. It may or may not be supported by

SANE. Try scanimage -L and read the backend's manpage.

...
$ _

Xsane bietet mir den Scanner als

Canon CanoScan LiDE25 Flachbettscanner [plustek:libusb:001:002]

an. Also drücke ich flugs auf „Scannen“ und warte. Es passiert nichts. Vorerst nichts. Dann wird als Scanergebnis ein schwarzes Bild angezeigt, ohne das der Scanner auch nur einen Mucks tut.
Starte ich Xsane aus der Konsole, erscheint keine Fehlermeldung. Also muss die Kommandozeile zum Scannen herhalten:

$ scanimage -d plustek:libusb:001:002 --format=jpg > test.jpg
$ _

Der Scanner beginnt zu Schnurren und erzeugt ein Bild. Na prima! Nacheinander probierte ich SimpleScan, Xsane, Gimp und Skanlite aus. Alle grafischen Programme liefern ein schwarzes Bild, ohne den Scanner zu benutzen! Auf der Kommandozeile funktioniert es tadellos.

Es sei noch kurz angemerkt, dass dieses Problem bei Manjaro XFCE nicht auftritt. Diverse Lösungsansätze in den einschlägigen Foren enden meist mit der Frage, ob der Inhaber des Problems denn auch in der Gruppe „scanner“ sei, denn das sei nötig. Meine Antwort darauf ist die, dass ich bei meinem XFCE nicht Mitglied dieser Gruppe bin, bei LXQt aber schon. Hier kann also nicht ganz stimmen, dass die Zugehörigkeit zu dieser Gruppe obligatorisch ist.
Sämtliche Versuche, mit Hilfe der Konfigurationsdatei /etc/sane.d/plustek.conf zum Ziel zu gelangen, schlagen ebenfalls fehl. Selbst das Umbennen und der anschließende Aufruf von Xsane ohne diese Konfiguration endet mit dem bekannten Ergebnis.
Auch die Bibliotheken, Back- und Frontends für sane sind da, in beiden Manjaro-Versionen werkelt der gleiche Kernel, beide Versionen sind testing. In XFCE geht’s, in LXQt nicht …

So betrachtet stimmt die Überschrift nicht ganz. Der Scanner scannt – aber eben nur auf der Kommandozeile. Das ist angesichts des Vorhandenseins einer grafischen Benutzeroberfläche inakzeptabel. Ich bleibe da mal dran und boote derweil abwechselnd XFCE und LXQt. Und wenn sich jetzt jemand fragt, weshalb ich die andere Desktopumgebung nicht einfach auf meine bestehende Installation gepflanzt habe, so ist die Antwort ganz einfach: Ich mag den dann entstehenden Misch-Masch nicht. Qt- und GTK-Anwendungen durcheinander – das ist nicht mein Ding.

3 Gedanken zu „Der Scanner will noch nicht …

Meinen Senf dazugeben

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s